This project has moved and is read-only. For the latest updates, please go here.

LUMT Privacy mode

Feb 27, 2014 at 9:53 PM
For using the Privacy mode modifications, is there anything specific server wise that needs to be enabled for that to take place? The tool works flawlessly, but when I try to do anything privacy related it just bombs.

2014-02-27 15:43:53 INFO Starting LUMT platform...
2014-02-27 15:43:56 INFO LUMT platform started.
2014-02-27 15:43:56 INFO Processing user sip:<emailaddress>...
2014-02-27 15:43:59 ERROR Error while processing user sip:<emailaddress>: The endpoint was unable to register. See the ErrorCode for specific reason.
2014-02-27 15:43:59 INFO Shutting down LUMT platform...
2014-02-27 15:44:00 INFO LUMT platform shut down.

I'm using a Lync 2013 client that was just updated to the latest built via Office 2012 SP1 32-bit, if that makes any different. Awesome tool, let me know if you can think of anything.
Feb 27, 2014 at 11:28 PM
I think I might have found the solution. We don't have enhanced privacy mode enable, so everyone is already set to public, but we're wanting a select few to be private.
Jun 9, 2014 at 5:25 PM
Unfortunately when you enable Enhanced Private Mode in Lync Server, everybody is set to Private by default. So you must use LUMT to set everybody to Public but not people you want to keep with Private setting.
Marked as answer by StefanPlizga on 9/22/2015 at 9:13 AM
Dec 11, 2015 at 1:10 PM
I've got the same error. But when i run the following command "LUMT.exe /Mode:Privacy /PrivacyPreference:Public /UsersFile:C:\LUMT\Users.txt" on the LUMT server i still receive this error.

2015-12-11 13:41:31 INFO Starting LUMT platform...
2015-12-11 13:41:35 INFO LUMT platform started.
2015-12-11 13:41:35 INFO Processing user sip:<emailaddress>...
2015-12-11 13:42:53 ERROR Error while processing user sip:<emailaddress>: The endpoint was unable to register. See the ErrorCode for specific reason.
2015-12-11 13:42:53 INFO Shutting down LUMT platform...
2015-12-11 13:42:53 INFO LUMT platform shut down.

I'm using Windows Server 2012 R2 Standard. Is there any other solution for this problem?
Dec 11, 2015 at 4:34 PM
Hello,
Did you use version 1.2.0.0 of LUMT? I think it should give more details about the error.
Thanks,
Stefan
Dec 17, 2015 at 9:19 AM
Hi Stefan,

Yes, i'm using version 1.2.0.0. Is there another location where error details will be stored?
Dec 17, 2015 at 1:05 PM
Hi Graham12,
I see, the error details is not implemented for privacy. I modified it and created version 1.3.0.0. That should give more details about the error.
Stefan
Dec 22, 2015 at 8:10 AM
Hi Stefan,

Thank you for the modification.

After installing LUMT 1.3.0.0 i'm receiving the following error.

2015-12-22 09:01:16 INFO Starting LUMT platform...
2015-12-22 09:01:24 INFO LUMT platform started.
2015-12-22 09:01:24 INFO Processing user sip:<emailaddress>...
2015-12-22 09:02:43 ERROR Error while processing user sip:<emailaddress>: The endpoint was unable to register. See the ErrorCode for specific reason.. Inner Exception: N/A
2015-12-22 09:02:43 INFO Shutting down LUMT platform...
2015-12-22 09:02:44 INFO LUMT platform shut down.

Graham
Jan 4, 2016 at 1:44 PM
Hi Graham12,
It is weird, it looks like there is no additional information available about the error. Could you explain a bit your architecture and the way you installed LUMT?
Jan 4, 2016 at 4:38 PM
Hi Graham12,
I put a change to increase error logging for your specific scenario, now you should get more details with version 1.4.0.0.
Please come back to me with the result, even if this make you understanding where the issue come from.
Thank you