LUMT Error

Jul 8, 2013 at 2:58 PM
Edited Jul 9, 2013 at 7:56 AM
Hi All,

i ask for resolve my problem. This is a log after LUMT usage:

2013-07-09 09:45:10 INFO Starting LUMT platform...
2013-07-09 09:45:15 INFO LUMT platform started.
2013-07-09 09:45:15 INFO Processing user sip:user@damain.local... 2013-07-09 09:45:16 ERROR Error while processing user sip:user@damain.local: The target principal name is incorrect
2013-07-09 09:45:16 INFO Shutting down LUMT platform...
2013-07-09 09:45:16 INFO LUMT platform shut down.

I've configured everything how you explain in the Setup configuration. But now i can't go ahead.
Thx
Bye
Jul 15, 2013 at 9:04 PM
Axel10 - you seem to have gotten the connection setup..?

Where you able to get past this error message?

Setup the Server Connection

However when I Run LUMT

2013-06-20 12:24:59 INFO Starting LUMT platform...
2013-06-20 12:25:14 ERROR LUMT platform NOT started: One or more values in the configured settings are invalid or unusable. Check inner exception and logs for more details.

LUMT.exe /Mode:Contact /UsersFile:users.txt /ContactsFile:contacts.txt /ContactsGroup:Test

User.txt and Contacts.txt has sip:username@domain.org

Suggestions??
Jul 16, 2013 at 7:55 AM
Hi CodePlexTester85,

about your error log, i ask you: have you followed step by step the Setup Configuration described in a Documentation tabs ?

In substance, for a working LUMT "server" you have to:
  1. use LUMT tool in another server and not on you primary site server of Lync
  2. create, on your primary site server of Lync, an other UCMA application called LUMT using Lync Powershell Console following the procedure described in a Documentation guide
  3. install, using media of Lync Deployement, the component of Lync server in a the LUMT dedicated server
  4. hope for the best that everything goes well :-)
this is what i did. And however i get my error. So i can't help you much more.

Bye
Jul 22, 2013 at 4:25 PM
Thanks - Started over on a fresh server and is working great now.
Coordinator
Oct 4, 2013 at 4:22 PM
Great to know. It should be fine by following the documentation in CodePlex. If not, please tell me what step is wrong and I will fix it.
Oct 30, 2013 at 8:47 AM
Hi Stefan,

have you a solution to resolve my problem ?
The line in log : "user sip:user@damain.local: The target principal name is incorrect" what exactly means ?

Thanks
Bye
Coordinator
Oct 30, 2013 at 1:28 PM
Hi,
Could you provide more details on what your setup is?
If the server when LUMT is running a member of the Active Directory domain?
Oct 31, 2013 at 8:47 AM
Hi Stefan,

i've setup my LUMT server following the documentation.
The only dubt about the current configuration is that in my infrastructure there is a principal domain and childs domain.
The Lync server and LUMT server are member of the same child domain, i ask if this can is the problem.

Es.:
domain.local ( principal domain )
city.domain.local ( child domain )

lync.city.domain.local ( lync server FQDN )
ucma.city.domain.local ( LUMT server FQDN )

This is the log if i try to update the contact list for any user:

2013-10-30 10:20:09 INFO Starting LUMT platform...
2013-10-30 10:20:12 INFO LUMT platform started.
2013-10-30 10:20:12 INFO Processing user sip:[email removed]...
2013-10-30 10:20:13 ERROR Error while processing user sip:[email removed]: The target principal name is incorrect
2013-10-30 10:20:13 INFO Shutting down LUMT platform...
2013-10-30 10:20:13 INFO LUMT platform shut down.

I don't know if LUMT Platform can work across the domain hierarchy, though the entire Lync infrastructure can work across the multiple domain hierarchy.

Thanks
Bye

Alessio Orizio


Coordinator
Jul 17, 2015 at 9:45 AM
Hello,
I released version 1.1.0.0 that should give you more details on the issue. Let's try it and report the issue.
Marked as answer by StefanPlizga on 9/22/2015 at 9:10 AM
Mar 10, 2016 at 5:39 AM
I have installed version 1.4.0.0 and I still get a similar error above.

2016-03-10 00:30:34 INFO Starting LUMT platform...
2016-03-10 00:30:37 INFO LUMT platform started.
2016-03-10 00:30:37 INFO Processing user sip:buddylist1@adventureworks.com... 2016-03-10 00:30:38 ERROR Error while processing user sip:buddylist1@adventureworks.com: The target principal name is incorrect. Inner Exception: outgoing TLS negotiation failed; Wrong target principal name configured. HRESULT=-2146893022
2016-03-10 00:30:38 INFO Shutting down LUMT platform...
2016-03-10 00:30:38 INFO LUMT platform shut down.

Seems to me a certificate mismatch issue, but the default cert on our FE server is the FQDN of the server joined to AD also the common name of the certificate. This is Skype for Business Server 2015 Standard Edition. Running LUMT on one of our SDN managers (using http), but added to our topology as a trusted application server per the documentation here.
Coordinator
Mar 16, 2016 at 11:10 AM
This may be related to a certificate issue, you must give more information about your setup:
  • Did you installed binaries like described in the last step of the Setup documentation?
  • On your LUMT server, what is the information for Subject Name and Subject Alternative Name fields for the certificate?
  • On your SfB server, what is the information for Subject Name and Subject Alternative Name fields for the certificate used by the SfB server?
  • Do you use have all DNS records set up to allow automatic discovery of the SfB server (sip.domain.com, _sipinternaltls._tcp.domain.com, etc...)?